UVA-1121 - Subsequence(尺取法)

题目链接

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

尺取法,非常简单,水题:

//一页 27行就很舒服 
#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
//#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
#define INF 0x3f3f3f3f  
#define mod 998244353
//#define max(a,b) (a)>(b)?(a):(b)
//#define min(a,b) (a)<(b)?(a):(b) 
#define clean(a,b) memset(a,b,sizeof(a))// 水印 
//std::ios::sync_with_stdio(false);
int shuzu[100100];

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n,m;
		while(cin>>n>>m)
		{
			clean(shuzu,0);
			int i,j;
			for(i=0;i<n;++i)
				cin>>shuzu[i];
			ll l=0,sum=0,str=0,minl=1e10;
			if(shuzu[0]>=m)
			{
				cout<<1<<endl;
				continue;
			}
			for(i=0;i<n;++i)
			{
				sum=sum+shuzu[i];
				++l;
				while(sum-shuzu[str]>=m)
				{
					sum=sum-shuzu[str];
					str++;
					--l;
					minl=minl<l?minl:l;
				}
			}
			if(minl==1e10&&sum<m)
			{
				cout<<0<<endl;
				continue;
			}
			minl=minl<l?minl:l;
			cout<<minl<<endl;
		}
	}
	
}

猜你喜欢

转载自blog.csdn.net/qq_40482358/article/details/81711947