HDOJ--1008Elevator

原题链接


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case. 
 

Sample Input
 
  
1 2 3 2 3 1 0
 

Sample Output
 
  
17 41
 

思路:开始从第0层开始,最后到达的时候还要加上停止5s。


代码:

#include<stdio.h>

int main()
{
	int i,N,result,FloorNum,NextFloor;
	while(scanf("%d",&N)&&N)
	{
		result=0;FloorNum=0;
		for(i=1;i<=N;i++)
		{
			scanf("%d",&NextFloor);
			if(NextFloor>FloorNum)
			{
				result=result+(NextFloor-FloorNum)*6+5;
				FloorNum=NextFloor;
			}
			else{
				result=result+(FloorNum-NextFloor)*4+5;
				FloorNum=NextFloor;
			}
		}
		printf("%d\n",result);
	}
	return 0;
}



猜你喜欢

转载自blog.csdn.net/y_cnew/article/details/79836236