基础dp(2) POJ 1458 Common Subsequence

题目:

http://poj.org/problem?id=1458

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

解析 :

本题需要我们求解给出的两个字符串中的最长公共子序列。

可以使用maxlen(i,j)表示s1字符串的i个子串与s2字符串的j个子串形成的最长公共子序列长度,其中的i,j都从0开始计算。显然当s1的0个字符与s2相比较或s2的0个字符与s1相比较时,所得的结果都为0,所以考虑到边界情况可以设置maxlen(i,0)=0,maxlen(0,j)=0。当s1的第i-1个字符与s2的第j-1个字符相等时:maxlen(i,j)=maxlen(i-1,j-1)+1 。而当末端字符不相同时,maxlen(i,j)=max(maxlen(i-1,j),maxlen(i,j-1)) 。

AC代码:

#include<iostream>
#include<cstring>
using namespace std;
char s1[1000];
char s2[1000];
int maxlen[1000][1000];
int main()
{
	while (cin >> s1 >> s2)
	{
		int len1 = strlen(s1);
		int len2 = strlen(s2);
		int i, j;
		for (i = 0; i <= len1; i++)
		{
			maxlen[i][0] = 0;
		}
		for (j = 0; j <= len2; j++)
		{
			maxlen[0][j] = 0;
		}
		for (i = 1; i <= len1; i++)
		{
			for (j = 1; j <= len2; j++)
			{
				if (s1[i - 1] == s2[j - 1])
				{
					maxlen[i][j] = maxlen[i - 1][j - 1] + 1;
				}
				else
					maxlen[i][j] = max(maxlen[i - 1][j], maxlen[i][j - 1]);
			}
		}
		cout << maxlen[len1][len2] << endl;
	}
	return 0;
}

cs202 fanyuchen 

猜你喜欢

转载自blog.csdn.net/zjsru_Beginner/article/details/119967880
今日推荐