简单dp(多重背包问题)

Coins

Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 31369   Accepted: 10679

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source

LouTiancheng@POJ

题目的意思:
  第一行输入,n,m分别表示n种硬币,m表示总钱数。
  第二行输入n个硬币的价值,和n个硬币的数量。
  输出这些硬币能表示的所有在m之内的硬币种数。
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
#define N 0x3f3f3f3f
using namespace std;
int a[110];
int b[110];
int mark[100010];
int num[100010];
int main()
{
	int n,m;
	while(cin>>n>>m)
	{
	
	if(n==0&&m==0)
	break;
	for(int i=1;i<=n;i++)
	cin>>a[i];//记录钱的面值 
	for(int i=1;i<=n;i++)
	cin>>b[i];//记录该钱的个数 
	memset(mark,0,sizeof(mark));
	mark[0]=1;//标记钱的组合的是否之前出现过 
	int ans=0;//统计不同组合的个数 
	for(int i=1;i<=n;i++)
	{
		memset(num,0,sizeof(num));//每次组合都是新的开始,故钱的数量不变 
		for(int j=a[i];j<=m;j++)
		{
			if(mark[j]==0&&mark[j-a[i]]&&num[j-a[i]]<b[i])
			//mark[j] 判断是否之前有过此组合
			//mark[j-a[i]] 判断是否前面有此组合 
			//num[j-a[i]] 判断该面值的钱是否已经用完 只需判断b[i] 是否满足
			//不用判断num[j-a[i]] 因为既然num[j-a[i]]存在 则说明此钱够用 
			{
				num[j]=num[j-a[i]]+1;
				ans++;
				mark[j]=1;	
			}
		}
	}
	cout<<ans<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81107421