G - Game Rank (模拟)

The gaming company Sandstorm is developing an online two player game. You have been asked to implement the ranking system. All players have a rank determining their playing strength which gets updated after every game played. There are 25 regular ranks, and an extra rank, “Legend”, above that. The ranks are numbered in decreas- ing order, 25 being the lowest rank, 1 the second highest rank, and Legend the highest rank.

Each rank has a certain number of “stars” that one needs to gain before advancing to the next rank. If a player wins a game, she gains a star. If before the game the player was on rank 6-25, and this was the third or more consecutive win, she gains an additional bonus star for that win. When she has all the stars for her rank (see list below) and gains another star, she will instead gain one rank and have one star on the new rank.

For instance, if before a winning game the player had all the stars on her current rank, she will after the game have gained one rank and have 1 or 2 stars (depending on whether she got a bonus star) on the new rank. If on the other hand she had all stars except one on a rank, and won a game that also gave her a bonus star, she would gain one rank and have 1 star on the new rank. If a player on rank 1-20 loses a game, she loses a star. If a player has zero stars on a rank and loses a star, she will lose a rank and have all stars minus one on the rank below. However, one can never drop below rank 20 (losing a game at rank 20 with no stars will have no effect).

If a player reaches the Legend rank, she will stay legend no matter how many losses she incurs afterwards. The number of stars on each rank are as follows:

• Rank 25-21: 2 stars

• Rank 20-16: 3 stars

• Rank 15-11: 4 stars

• Rank 10-1: 5 stars

A player starts at rank 25 with no stars. Given the match history of a player, what is her rank at the end of the sequence of matches?

Input

There will be several test cases. Each case consists of a single line describing the sequence of matches. Each character corre- sponds to one game; ‘W’ represents a win and ‘L’ a loss. The length of the line is between 1 and 10 000 characters (inclusive).

Output

Output a single line containing a rank after having played the given sequence of games; either an integer between 1 and 25 or “Legend”.

Sample Input

WW
WWW
WWWW
WLWLWLWL
WWWWWWWWWLLWW
WWWWWWWWWLWWL

Sample Output

25
24
23
24
19
18

【解析】

就是炉石的排位机制。。。

共25个等级和传说等级,

赢一局一颗星,连续赢三局以上额外多加一颗星(高于5级后不多加星),满星后再多一颗星才能升等级,并且升级后新等级有一颗星。

输一局减一颗星(21-25级输了不扣星,但是仍会断连胜),输了后没星仍可以保持段位,但是没星后又掉星了会掉等级。传说后不论输赢均不掉段。

各等级的星星为

• Rank 25-21: 2 stars

• Rank 20-16: 3 stars

• Rank 15-11: 4 stars

• Rank 10-1: 5 stars

限制条件实在是太多了。。。。。。

#include<iostream>
#include<cstdio>
#include<cstring> 
using namespace std;
int a[30]= { 5, 5, 5, 5, 5, 5, 5, 5, 5, 5, 5, 4, 4, 4, 4, 4, 3, 3, 3, 3, 3, 2, 2, 2, 2, 2 };
char s[10005];
int main()
{
	while (~scanf("%s", s))
	{
		int rank = 25, stars = 0, time = 0;
		for (int i = 0; i < strlen(s); i++)
		{
			if (rank==0)break;
			if (s[i] == 'W')
			{
				stars++;
				if (rank > 5 && ++time >= 3) stars++;
				if (stars > a[rank]) 
				{
					stars -= a[rank];
					rank--;
				}
			}
			else
			{
				time = 0;
				if (rank >= 21)continue;
				stars--;
				if (stars < 0)
				{
					if (rank == 20)
						stars = 0;
					else 
					{
						rank++;
						stars = a[rank] - 1;
					}
				}
			}
		}
		if (rank)printf("%d\n", rank);
		else printf("Legend\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/waterboy_cj/article/details/81541700