G - A New Stone Game

Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

Input

The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.

Output

For each test case, if Alice win the game,output 1,otherwise output 0.

Sample Input

3
2 1 3
2
1 1
0

Sample Output

1
0

题意概括  :

给你n堆物品,每次可以从容易一堆物品中取出任意数量的物品然后从剩下的石子中取出任意数量的石子扔掉或加入其他堆石子中,问先手胜输出1否则输出1.

解题思路  :

把每堆物品的数量当做另一个数组的下标,然后下标内部进行排序,判断如果堆数数量相等的为偶数堆,则输出1,否则输出0.

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>

using namespace std;

int a[11],num[110];

int main()
{
	int n,number,i,z;

	while(~ scanf("%d",&n))
	{
		memset(num,0,sizeof(num));
		if(n == 0)
		break;
		for(i = 0 ; i < n;i ++)
		{
			scanf("%d",&a[i]);
			num[a[i]] ++;
		}
		sort(a,a+1);
		number = 0;
		for(i = 0; i<= 100;i ++)
		{
			if(num[i]%2==1)
			number ++;
		}
		if(number!=0)
		printf("1\n");
		else
		printf("0\n");
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81142847