Game Rank(模拟)

Description

The gaming company Sandstorm is developing an online two player game. You have been asked to implement the ranking system. All players have a rank determining their playing strength which gets updated after every game played. There are 25 regular ranks, and an extra rank, “Legend”, above that. The ranks are numbered in decreas- ing order, 25 being the lowest rank, 1 the second highest rank, and Legend the highest rank.

Each rank has a certain number of “stars” that one needs to gain before advancing to the next rank. If a player wins a game, she gains a star. If before the game the player was on rank 6-25, and this was the third or more consecutive win, she gains an additional bonus star for that win. When she has all the stars for her rank (see list below) and gains another star, she will instead gain one rank and have one star on the new rank.

For instance, if before a winning game the player had all the stars on her current rank, she will after the game have gained one rank and have 1 or 2 stars (depending on whether she got a bonus star) on the new rank. If on the other hand she had all stars except one on a rank, and won a game that also gave her a bonus star, she would gain one rank and have 1 star on the new rank. If a player on rank 1-20 loses a game, she loses a star. If a player has zero stars on a rank and loses a star, she will lose a rank and have all stars minus one on the rank below. However, one can never drop below rank 20 (losing a game at rank 20 with no stars will have no effect).

If a player reaches the Legend rank, she will stay legend no matter how many losses she incurs afterwards. The number of stars on each rank are as follows:

• Rank 25-21: 2 stars

• Rank 20-16: 3 stars

• Rank 15-11: 4 stars

• Rank 10-1: 5 stars

A player starts at rank 25 with no stars. Given the match history of a player, what is her rank at the end of the sequence of matches?

Input

There will be several test cases. Each case consists of a single line describing the sequence of matches. Each character corre- sponds to one game; ‘W’ represents a win and ‘L’ a loss. The length of the line is between 1 and 10 000 characters (inclusive).

Output

Output a single line containing a rank after having played the given sequence of games; either an integer between 1 and 25 or “Legend”.

Sample Input

WW
WWW
WWWW
WLWLWLWL
WWWWWWWWWLLWW
WWWWWWWWWLWWL

Sample Output

25
24
23
24
19
18

解析

 游戏机制跟王者段位机制很相似,每赢一场加一颗星,当段位在6-25之间若达到3连胜以上每场获胜加两颗星,输一场连胜中断。当段位在1-20之间每输一场掉一颗星,最低段位为25;当段位达到legend时(即段位<1时),怎么输都不掉星。

代码

#include<stdio.h>
#include<string.h>
#define MAX 10005
int main()
{
    char game[MAX];
    int level[26]={0,5,5,5,5,5,5,5,5,5,5,4,4,4,4,4,3,3,3,3,3,2,2,2,2,2};
        //每个段位需要的星星数                                                                            
    while(~scanf("%s",game))
    {
        int len=strlen(game);
        int now=25,star=0,flag=0,c=0; 
        //now为当前段位,star为获得的星星数,flag记录段位是否达到legend
        for(int i=0;i<len;i++)
        {
            if(game[i]=='W')
            {
                c++; //记录连胜次数
                if(c>=3&&now>=6) //段位在6以下并且连胜三局及以上
                    star+=2;
                else
                    star+=1;
                if(star>level[now]) //当所获星星数超出当前段位要求
                {
                   while(star>level[now])
                   {
                       star-=level[now];
                       now--;
                   }
                }
            }
            else
            {
               if(now>=1&&now<20)
                  star-=1;
               else if(now==20&&star!=0)
                  star-=1;
               if(star<0&&now<25)
               {
                   now++;
                   star+=level[now];
               }
               c=0; //连胜中断
            }
            if(now<=0) //达到传奇段位
            {
               flag=1;
               break;
            }
        }
        if(flag)
            printf("Legend\n");
        else
            printf("%d\n",now);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/81541545