PAT Advanced1012 The Best Rank(排序,模拟)

版权声明:个人学习笔记记录 https://blog.csdn.net/Ratina/article/details/85528413

链接:PAT Advanced1012

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.


For example, The grades of C, M, E and A - Average of 4 students are given as the following:


StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.


The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.


If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A



题目大意:给出学生ID和C、M、E三门课程成绩,分别按A(平均分)、C、M、E成绩排序得到排名。每个学生取其 最高排名对应课程,若一个学生有2个或以上相同的最高排名,对应课程选取优先级为 A > C > M > E。


思路:以 A、C、M、E 的顺序排序4次,若下一次的排名比上一次的高,则更新,反之不变动(这样可以保证优先级为A > C > M > E)。
此外,排名时相同分数的名次应当相同。



以下代码:

#include<bits/stdc++.h>
using namespace std;
struct stu
{
	string ID;
	int C,M,E;
	double A;
	int best_rank;
	char best_course;
	stu(){
		best_rank=INT_MAX;   //初始化一下最高排名
	}
};
bool Acmp(stu a,stu b){ return a.A>b.A; }
bool Ccmp(stu a,stu b){ return a.C>b.C; }
bool Mcmp(stu a,stu b){ return a.M>b.M; }
bool Ecmp(stu a,stu b){ return a.E>b.E; }
void give_rank_A(stu *a,int n)    //以A排名
{
	sort(a,a+n,Acmp);
	int i,pre;
	for(i=0;i<n;i++)
	{
		int t;
		if(i!=0&&a[i].A==a[i-1].A)   //若分数相同则名次相同
			t=pre;
		else
			t=i+1;
		if(t<a[i].best_rank)         //若排名比上一次高,则更新
		{
			a[i].best_rank=t;
			a[i].best_course='A';
		}
		pre=t;
	}
}
void give_rank_C(stu *a,int n)   //同上
{
	sort(a,a+n,Ccmp);
	int i,pre;
	for(i=0;i<n;i++)
	{
		int t;
		if(i!=0&&a[i].C==a[i-1].C)
			t=pre;
		else
			t=i+1;
		if(t<a[i].best_rank)
		{
			a[i].best_rank=t;
			a[i].best_course='C';
		}
		pre=t;
	}
}
void give_rank_M(stu *a,int n)   //同上
{
	sort(a,a+n,Mcmp);
	int i,pre;
	for(i=0;i<n;i++)
	{
		int t;
		if(i!=0&&a[i].M==a[i-1].M)
			t=pre;
		else
			t=i+1;
		if(t<a[i].best_rank)
		{
			a[i].best_rank=t;
			a[i].best_course='M';
		}
		pre=t;
	}
}
void give_rank_E(stu *a,int n)   //同上
{
	sort(a,a+n,Ecmp);
	int i,pre;
	for(i=0;i<n;i++)
	{
		int t;
		if(i!=0&&a[i].E==a[i-1].E)
			t=pre;
		else
			t=i+1;
		if(t<a[i].best_rank)
		{
			a[i].best_rank=t;
			a[i].best_course='E';
		}
		pre=t;
	}
}
int main()
{  
	stu a[2010];
	int N,M,i;
	map<string,stu> ans;
	cin>>N>>M;
	for(i=0;i<N;i++)   //读入并计算平均分
	{
		cin>>a[i].ID>>a[i].C>>a[i].M>>a[i].E;
		a[i].A=double(a[i].C+a[i].M+a[i].E)/3.0;
	}
	give_rank_A(a,N);
	give_rank_C(a,N);
	give_rank_M(a,N);
	give_rank_E(a,N);
	for(i=0;i<N;i++)       //存入map容器中,方便查找
		ans[a[i].ID]=a[i];
	for(i=0;i<M;i++)       //查找,输出
	{
		string t;
		cin>>t;
		if(ans.count(t))
			cout<<ans[t].best_rank<<" "<<ans[t].best_course<<endl;
		else
			cout<<"N/A"<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Ratina/article/details/85528413