[二分-最大化最小值]POJ - 3258

River Hopscotch
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 17955   Accepted: 7505

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).



题意:

牛要到河对岸,在与河岸垂直的一条线上,河中有N块石头,给定河岸宽度L,以及每一块石头离牛所在河岸的距离,

 现在去掉M块石头,要求去掉M块石头后,剩下的石头之间以及石头与河岸的最小距离的最大值。

看到题目很明显就是一个最大化最小值的问题,

这种问题对于小的值来说都是满足的,而我们需要寻找的最大的哪个能满足这个条件的,很显然是满足单调性的

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 1e5+10;
const int inf = 1e9+10;
vector<int> arr;
int n,c;
/*bool check(int mid) {
    int cnt = 1;
    vector<int>::iterator it = arr.begin();
    while(it != arr.end()) {
        it = lower_bound(arr.begin(),arr.end(),mid+*it);
        if(it != arr.end()) cnt++;
    }
    return cnt >= c;
}*/
bool check(int mid) {
    int cnt = 1,i = 1,it = 0;
    while(i < n) {
        if(arr[i] < arr[it] + mid) i++;
        else it = i,cnt++,i++;
    }
    return cnt >= c;
}
int main()
{
    while(~scanf("%d%d",&n,&c)) {
        for(int i=0;i<n;i++){
            int x;scanf("%d",&x);
            arr.push_back(x);
        }
        sort(arr.begin(),arr.end());
        int right = inf,left = 0;
        while(left <= right) {
            int mid = (right + left) / 2;
            if(check(mid)) left = mid + 1;
            else right = mid - 1;
        }
        printf("%d\n",right);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_38013346/article/details/79966623