POJ2456-Aggressive cows 二分搜索(最大化最小值)

Aggressive cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20201   Accepted: 9573

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.
 
题意:有M头牛和N间小屋,把这M头牛放到N间小屋中,使牛之间的最小距离尽可能大,输出牛之间的最小距离
思路:这是二分搜索中最大化最小值问题,可以粗略的先求出解的范围,然后对这些解进行二分搜索
代码:
#include <stdio.h>    
#include <iostream>
#include <algorithm>
#include <string>
#define maxx 100009
#define fio ios::sync_with_stdio(false);cin.tie(0);cout.tie(0)

using namespace std;

int n, m;
int house[maxx];
int ans;

bool isright(int d) {
    int count;
    for (int a = 1; a <= n - m + 1; a++) {
        count = 1;
        if ((house[n] - house[a]) / (m - 1) < d) {
            return 0;
        }
        for (int i = a+1; i <= n; i++) {
            if (house[i] - house[a] >= d) {
                count++;
                a = i;
            }
        }
        if (count >= m) {
            return 1;
        }
    }
    return 0;
}

void erfenfind(int l, int r) {
    if (l == r || isright(r)) {
        ans = r;
    }
    else {
        int mid = (l + r) / 2;
        if (isright(mid)) {
            erfenfind( mid, r-1);
        }
        else {
            erfenfind(l, mid-1);
        }
    }
}

int main() {
    fio;

    cin >> n >> m;
    for (int i = 1; i <= n; i++) {
        cin >> house[i];
    }
    sort(house + 1, house + 1 + n);
    ans = 0;

    int inf =( (house[n]-house[1]) / (m-1));
    erfenfind(0, inf);
     
    cout << ans << endl;

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/the-way-of-cas/p/9417770.html