Greatest Common Increasing Subsequence

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output

output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2

题意:求两个序列的最长公共上升子序列的长度。

思路:dp[ j ] 记录在第一个数组的第 i 项时,第二个数组的第 j 项能达到的最长公共上升子序列的长度。滚动更新,最后求dp的最大值即可。

代码如下:

#include<cstdio>
#include<cstring>
int main()
{
    long long s[550],t[550];
    int dp[550];
    int tt;
    scanf("%d",&tt);
    while(tt--)
    {
        int m,n;
        scanf("%d",&m);
        for(int i=0;i<m;i++)
            scanf("%lld",&s[i]);
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%lld",&t[i]);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<m;i++)   //以s数组为比照,选定一个数依次和t内值比较
        {
            int maxx=0;       //这个位置可能达到的最大值
            for(int j=0;j<n;j++)
            {
                if(s[i]>t[j]&&dp[j]>maxx)  //更新最大长度,但要满足选定的这个数大于此时的数,突出上升子序列
                    maxx=dp[j];
                if(s[i]==t[j])             //得到公共数的时候,maxx+1
                    dp[j]=maxx+1;
            }
        }
        int maxx=0;
        for(int i=0;i<n;i++)
            if(dp[i]>maxx)   //求最大长度
                maxx=dp[i];
        printf("%d\n",maxx);
        if(tt)
            printf("\n");
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41890797/article/details/81430395