PAT甲级 1020. Tree Traversals

1020. Tree Traversals (25)
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

题目大意:给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
分析:与后序中序转换为前序的代码相仿(无须构造二叉树再进行广度优先搜索~~),只不过加一个变量index,表示当前的根结点在二叉树中所对应的下标(从0开始),所以进行一次输出先序的递归的时候,就可以把根结点下标所对应的值存储在level数组中(一开始把level都置为-1表示此处没有结点),这样在递归完成后level数组中非-1的数就是按照下标排列的层序遍历的顺序~~~

代码实现如下:

#include <iostream>
#include <vector>
using namespace std;

vector<int> post,in;
vector<int> level(10000,-1);//定义容量是1000的数组,容易要定大一些 

void pre(int startPost,int endPost,int startInorder, int endInorder,int index){
	if(startPost > endPost)//越界时停止递归 
		return;
	
	int rootValue = post[endPost];
	level[index] = rootValue;//通过下标记录层次遍历的节点顺序 
	
    int i = startInorder;
    while(i <= endInorder && in[i] != rootValue) i++;
    
    int leftLength = i - startInorder;
    pre(startPost,startPost+leftLength-1,startInorder,i-1,2*index+1);
    pre(startPost+leftLength,endPost-1,i+1,endInorder,2*index+2);
}

int main() {
    int n;
    cin>>n;
    
	post.resize(n);
	in.resize(n);//也可以这样动态设定vector容量大小,注意与容器数组的区别 
	
    for(int i=0;i<n;i++) 
		cin>>post[i];
    for(int i=0;i<n;i++)
    	cin>>in[i];
    	
    pre(0,n-1,0,n-1,0);
    
    int cnt = 0;
    for(int i=0;i<level.size();i++){
    	if(level[i]!=-1){
    		cout<<level[i];
    		cnt++;
    		if(cnt < n) 
				cout<<" ";
    	}
    	if(cnt==n)break;
    }
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/81484757