PAT 甲级 1020 Tree Traversals

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/86564200

1020 Tree Traversals (25 point(s))

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

Experiential Summing-up

This question is a classical work out someone order sequence according to inorder traversal sequence and another sequence. the way of handling it is very basic. So there is nothing else to say~

(The purpose of using English to portray my solution is that to exercise the ability of my expression of English and accommodate PAT advanced level's style.We can make progress together by reading and comprehending it. Please forgive my basic grammar's and word's error. Of course, I would appreciated it if you can point out my grammar's and word's error in comment section.( •̀∀•́ ) Furthermore, Big Lao please don't laugh at me because I just a English beginner settle for CET6    _(:з」∠)_  )

Accepted Code

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#include <vector>
using namespace std;
const int INF=0x3fffffff;
const int maxn=40;
int n,post[maxn],in[maxn];
vector<int> ans;
struct node
{
	node * lchild, * rchild;
	int data;
};
node * create(int inL,int inR,int postL,int postR)
{
	if(postL>postR)
		return NULL;
	int k;
	for(k=inL;k<=inR;++k)
	{
		if(in[k]==post[postR])
		{
			break;
		}
	}
	node * a=new node;
	a->data=post[postR];
	a->lchild=create(inL,k-1,postL,postL+(k-inL)-1);
	a->rchild=create(k+1,inR,postL+(k-inL),postR-1);
	return a;
}
void level(node * root)
{
	queue<node *> q;
	q.push(root);
	while(q.size())
	{
		node * x=q.front();
		ans.push_back(x->data);
		q.pop();
		if(x->lchild!=NULL)
			q.push(x->lchild);
		if(x->rchild!=NULL)
			q.push(x->rchild);
	}
}
int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;++i)
		scanf("%d",&post[i]);
	for(int i=0;i<n;++i)
		scanf("%d",&in[i]);
	node * root=create(0,n-1,0,n-1);
	level(root);
	for(int i=0;i<ans.size();++i)
	{
		printf("%d",ans[i]);
		if(i!=ans.size()-1)
			printf(" ");
		else
			printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/86564200