HDU-1698 Just a Hook

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 41010    Accepted Submission(s): 19775

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.


Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1

10

2

1 5 2

5 9 3

Sample Output

Case 1: The total value of the hook is 24.

思路:线段树

初识线段树的懒标记
区间更新的时候,可以加快更新的速度

-----------------------------------------------------------AC code ---------------------------------------------------------------

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

const int maxn = 1e5+5;

struct segtree{
    int l,r,sum;
    int lazy,tag;
}ss[maxn<<2];

void pushUp(int root){
    ss[root].sum = ss[root<<1].sum + ss[root<<1|1].sum;
}

void build(int l,int r,int root){
    ss[root].l = l, ss[root].r = r;
    ss[root].lazy = 0,ss[root].tag = 0;
    if(l == r) {
        ss[root].sum = 1;
        return;
    }
    int mid = (l+r)>>1;
    build(l,mid,root*2);
    build(mid+1,r,root*2+1);
    pushUp(root);
}

void update(int x,int y,int root,int val){
    if(ss[root].l == x && ss[root].r == y){
        ss[root].lazy = 1,ss[root].tag = val;
        ss[root].sum = (y - x + 1)*val;
        return;
    }
    int mid = (ss[root].l + ss[root].r)>>1;
    if (  ss[root].lazy == 1 ) {
        ss[root].lazy = 0;
        update(ss[root].l,mid,root*2,ss[root].tag);
        update(mid+1,ss[root].r,root*2+1,ss[root].tag);
        ss[root].tag = 0;
    }
    if ( mid >= y ) {
        update(x,y,root*2,val);
    } else if ( mid < x ) {
        update(x,y,root*2+1,val);
    } else {
        update(x,mid,root*2,val);
        update(mid+1,y,root*2+1,val); 
    }
    pushUp(root);
}

int main()
{
    int t,ncase = 1; scanf("%d",&t);
    while(t--)
    {
        int n,q,l,r,z; scanf("%d %d",&n,&q);
        build(1,n,1);
        for (int i = 0;i<q;i++){
            scanf("%d %d %d",&l,&r,&z);
            update(l,r,1,z);
        }
        printf("Case %d: The total value of the hook is %d.\n",ncase++,ss[1].sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Acer12138/article/details/81181319
今日推荐