【HDU 1698】Just a Hook(线段树)

Just a Hook


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

这里写图片描述

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.


Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.


Sample Input
1
10
2
1 5 2
5 9 3

Sample Output
Case 1: The total value of the hook is 24.


题意:

有一条铜钩,可以进行操作使其中的一段变为金银铜三种材质,价值分别为3,2,1,求最终这条钩子的价值。

思路:

如果某一段是纯色(金/银/铜),将子节点变为和父节点一样 ,直接计算即可。若某一段是杂色(金/银/铜混合),则搜索其左右子节点。将每段(这里的“每一段”是一个点)的价值加和求得总价值。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<iostream>
#define MAX 100005
using namespace std;
int ans;
struct TREE{
    int left;
    int right;
    int n;
}tree[MAX<<2];

void Build(int l,int r,int i)
{
    tree[i].left=l;
    tree[i].right=r;
    tree[i].n=1;
    if(l==r) return ;
    int mid=(l+r)/2;
    Build(l,mid,i*2);
    Build(mid+1,r,i*2+1);
}

void Updata(int l,int r,int type,int i)
{
    if(tree[i].n==type) return ;
    if(tree[i].left==l&&tree[i].right==r){
        tree[i].n=type;
        return ;
    }

    if(tree[i].n!=-1) //纯色 
    {
        tree[i*2].n=tree[i*2+1].n=tree[i].n;  //子节点变为和父节点一样 
        tree[i].n=-1; //变为杂色 
    } 
    //线段树套路 
    int mid=(tree[i].left+tree[i].right)/2;
    if(l>mid) Updata(l,r,type,i*2+1) ;
    else if(r<=mid) Updata(l,r,type,i*2);
    else 
    {
        Updata(l,mid,type,i*2);
        Updata(mid+1,r,type,i*2+1);
    } 
}

int Query(int i)
{
    if(tree[i].n!=-1)   //纯色--直接计算 
        return (tree[i].right-tree[i].left+1)*tree[i].n;
    else   //杂色--搜索子节点 
        return Query(i*2)+Query(i*2+1);
}

int main()
{
    int cas=1;
    int t,n,k,x,y,z;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&k); 
        Build(1,n,1);
        while(k--)
        {
            scanf("%d %d %d",&x,&y,&z);
            Updata(x,y,z,1);
        }
        printf("Case %d: The total value of the hook is %d.\n",cas++,Query(1));
    }
    return 0;
 } 

猜你喜欢

转载自blog.csdn.net/chen_yuazzy/article/details/77427920