HDU 1698 Just a Hook(线段树

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 42724    Accepted Submission(s): 20543


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 
Sample Input
1 10 2 1 5 2 5 9 3
 
Sample Output
Case 1: The total value of the hook is 24.
 
题意:屠夫初始时有n根铜钩,给你m次操作,修改区间内钩子的种类,(银是2,金是3)求经过m次操作后屠夫的攻击力是多少
题解:线段树的区间修改和区间查询
如果当前区间全部是同一种类的钩子的话就赋值为钩子种类代表的权值
否则就继续向下查询子树
代码如下:
#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+5;
int n,sum;
struct node{
    int l,r,s;
}t[maxn<<2];
void build(int l,int r,int num){
    t[num].l=l;
    t[num].r=r;
    t[num].s=1;
    if(l==r) return;
    int mid=(l+r)>>1;
    build(l,mid,num<<1);
    build(mid+1,r,num<<1|1);
}

void update(int l,int r,int m ,int num){
    if(t[num].s==m) return;
    if(t[num].l==l&&t[num].r==r){
        t[num].s=m;
        return ;
    }
    if(t[num].s!=-1){
        t[num<<1].s=t[num<<1|1].s=t[num].s;
        t[num].s=-1;
    }
    int mid=(t[num].l+t[num].r)>>1;
    if(l>mid) update(l,r,m,num<<1|1);
    else if(r<=mid) update(l,r,m,num<<1);
    else {
        update(l,mid,m,num<<1);
        update(mid+1,r,m,num<<1|1);
    }
}

int query(int num){
    if(t[num].s!=-1){
        return (t[num].r-t[num].l+1)*t[num].s;
    }else{
        return query(num<<1)+query(num<<1|1);  
    } 
}

int main(){
    int x,y,z,T,k;
    scanf("%d",&T);
    int cas=1;
    while(T--){
        scanf("%d%d",&n,&k);
        build(1,n,1);
        while(k--){
            scanf("%d%d%d",&x,&y,&z);
            update(x,y,z,1);
        }
        printf("Case %d: The total value of the hook is %d.\n",cas++,query(1));
    }
    return 0;
}
View Code

猜你喜欢

转载自www.cnblogs.com/buerdepepeqi/p/9445797.html