HDU - 1698 E - Just a Hook 区间覆盖+区间求和

注意线段树的初始化

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
 
  
1 10 2 1 5 2 5 9 3
 

Sample Output
 
  
Case 1: The total value of the hook is 24.
 

Source
 

Recommend
wangye


模板题

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e5+10;
struct SegTree
{
    ll sum[maxn<<2],lz[maxn<<2],cnt[maxn<<2];
    void init() {
        memset(sum,0,sizeof(sum));
        memset(lz,0,sizeof(lz));
        memset(cnt,0,sizeof(cnt));
    }
    void push_up(int rt) {
        sum[rt] = sum[rt<<1] + sum[rt<<1|1];
        cnt[rt] = cnt[rt<<1] + cnt[rt<<1|1];
    }
    void push_down(int rt) {
        if(!lz[rt]) return;
        lz[rt<<1] = lz[rt<<1|1] = lz[rt];
        sum[rt<<1] = lz[rt] * cnt[rt<<1];
        sum[rt<<1|1] = lz[rt] * cnt[rt<<1|1];
        lz[rt] = 0;  
    }
    void build(int l,int r,int rt) {
        if(l == r) {
            sum[rt] = 1;
            cnt[rt] = 1;
            lz[rt] = 0;
            return;
        } 
        push_down(rt);
        int mid = (l + r) >> 1;
        build(l,mid,rt<<1);
        build(mid+1,r,rt<<1|1);
        push_up(rt);
    }
    void update(int ql,int qr,ll val,int l,int r,int rt) {
        if(ql == l && qr == r) {
            sum[rt] = val*cnt[rt];
            lz[rt] = val;
            return;
        }
        push_down(rt);
        int mid = (l + r) >> 1;
        if(qr <= mid) update(ql,qr,val,l,mid,rt<<1);
        else if(ql > mid) update(ql,qr,val,mid+1,r,rt<<1|1);
        else {
            update(ql,mid,val,l,mid,rt<<1);
            update(mid+1,qr,val,mid+1,r,rt<<1|1);
        }
        push_up(rt);
    }
    ll query(int ql,int qr,int l,int r,int rt) {
        if(ql == l && qr == r) {
            return sum[rt];
        }
        push_down(rt);
        int mid = (l + r) >> 1;
        if(qr <= mid) return query(ql,qr,l,mid,rt<<1);
        if(ql > mid) return query(ql,qr,mid+1,r,rt<<1|1);
        return query(ql,mid,l,mid,rt<<1) + query(mid+1,qr,mid+1,r,rt<<1|1);
    }
}seg;
int main()
{
    int caset,t = 0;scanf("%d",&caset);
    while(caset--) {
        int n,q,l,r,z;
        scanf("%d%d",&n,&q);
        seg.init();             /// 注意初始化,因为有非叶节点的lz需要初始化.
        seg.build(1,n,1);       /// 也可以在build的时候push_down(rt)
        while(q--) {
            scanf("%d%d%d",&l,&r,&z);
            seg.update(l,r,z,1,n,1);
        }
        printf("Case %d: The total value of the hook is %lld.\n",++t,seg.query(1,n,1,n,1));
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/m0_38013346/article/details/80355435