Just a Hook(hdu 1698)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 42307    Accepted Submission(s): 20356

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
 


Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1 10 2 1 5 2 5 9 3

Sample Output

Case 1: The total value of the hook is 24.

Source

2008 “Sunline Cup” National Invitational Contest

lazy思想,疑惑中。。。先存着。。

#include<bits/stdc++.h>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=1e5+5;
int sum[maxn<<2],lazy[maxn<<2];
void init()//多样例,需要每次进行初始化
{
    memset(sum,0,sizeof(sum));
    memset(lazy,0,sizeof(lazy));
}
void pushup(int rt)//更新区间之和
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int rt,int len)
{
    if(lazy[rt])//如果标记存在的话,需要往下传递,然后删除该点的标记
    {
        lazy[rt<<1]=lazy[rt<<1|1]=lazy[rt];//传递
        sum[rt<<1]=(len-(len>>1))*lazy[rt];//如果区间长度为奇数时,左子树的区间长度要比右子树多1,因此这样计算
        sum[rt<<1|1]=(len>>1)*lazy[rt];//右子树的标记传递
        lazy[rt]=0;//删除标记
    }
}
void build(int l,int r,int rt)
{
    if(l==r)//建树
    {
        lazy[rt]=0;
        sum[rt]=1;
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);//更新
}
void update(int L,int R,int z,int l,int r,int rt)
{
    int len=r-l+1;
    if(L<=l&&r<=R)
    {
        sum[rt]=len*z;
        lazy[rt]=z;
        return;
    }
    pushdown(rt,len);//传递延迟标记,len是当前区间长度,用于求和
    int m=(l+r)>>1;
    if(L<=m) update(L,R,z,lson);
    if(m<R) update(L,R,z,rson);
    pushup(rt);//更新sum
}
int main()
{
    int T,n,q,a,b,z;
    scanf("%d",&T);
    for(int cas=1;cas<=T;cas++)
    {
        init();
        scanf("%d",&n);
        build(1,n,1);
        scanf("%d",&q);
        while(q--){
            scanf("%d%d%d",&a,&b,&z);
            update(a,b,z,1,n,1);//成段更新
        }
        printf("Case %d: The total value of the hook is %d.\n",cas,sum[1]);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41061455/article/details/81433177