HDU1698 Just a Hook(线段树)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 38844 Accepted Submission(s): 18849

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
img
Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

### 题意

  T组测试样例,每组样例有N个价值为1的物体,接着是Q个操作,对于每种操作,将修改区间[x,y]的物体价值为Z,最后求所有物体的和。

解题思路

  用线段树可以写,涉及到区间更新,甚至不用查询。区间更新的时候一定要注意初始化懒惰数组!贡献了几次WA。。

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+50;

int arr[maxn<<2],Add[maxn<<2];
void pushup(int rt)
{
    arr[rt]=arr[rt<<1]+arr[rt<<1|1];
}
void build(int l,int r,int rt)
{
    Add[rt]=0;
    if(l==r)
    {
        arr[rt]=1;
        return;
    }
    int m=(l+r)>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
    pushup(rt);
}
void pushdown(int rt,int ln,int rn)
{
    if(Add[rt])
    {
        Add[rt<<1]=Add[rt];
        Add[rt<<1|1]=Add[rt];
        arr[rt<<1]=Add[rt]*ln;
        arr[rt<<1|1]=Add[rt]*rn;
        Add[rt]=0;
    }
}
void update(int L,int R,int c,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        arr[rt]=c*(r-l+1);
        Add[rt]=c;
        return;
    }
    int m=(l+r)>>1;
    pushdown(rt,m-l+1,r-m);
    if(L<=m) update(L,R,c,l,m,rt<<1);
    if(R> m) update(L,R,c,m+1,r,rt<<1|1);
    pushup(rt);
}
int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    for(int k=1; k<=t; k++)
    {
        int n;
        cin>>n;
        build(1,n,1);
        int op;
        cin>>op;
        while(op--)
        {
            int l,r,val;
            cin>>l>>r>>val;
            update(l,r,val,1,n,1);
        }
        printf("Case %d: The total value of the hook is %d.\n",k,arr[1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36258516/article/details/80070384