Stars (树状数组)

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

题意:给你n个点,每个点都有一个等级,等级是这样定义的:在该点的左边和下边以及左下的点的总数即为该点的等级,现在要你统计0-n-1个等级的点的个数。注意:输入点的时候有一定的规则:会按纵坐标从小到大输入,如果纵坐标相等,则按横坐标从小到大。

思路:仔细想一想,其实这是一道很简单的树状数组(第一次看到这题的时候可不这么认为,,,)因为题目给出点的时候按照了纵横坐标从小到大的原则,而我们要统计的是该点的左下方的点的数量,每输入一个点都能保证之前的点都在它的下方,那么此时我们只需要统计在当前点的左方的点有多少就是它的等级了。

#include<stdio.h>
#include<string.h>
using namespace std;
const int N=32005;
int n,ans[N],c[N];
int lowbit(int i)
{
    return i&(-i);
}
void update(int i,int val)
{
    while(i<=N)
    {
        c[i]+=val;
        i+=lowbit(i);
    }
}
int sum(int i)
{
    int res=0;
    while(i>0)
    {
        res+=c[i];
        i-=lowbit(i);
    }
    return res;
}
int main()
{
    int x,y;
    while(~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        memset(ans,0,sizeof(ans));
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&x,&y);
            x++;
            ans[sum(x)]++;
            update(x,1);
        }
        for(int i=0; i<n; i++)
            printf("%d\n",ans[i]);
    }
}

猜你喜欢

转载自blog.csdn.net/Never__give__up/article/details/81355804