数据结构:树状数组:stars


 例题2:Stars


题目描述

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

输入

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

输出

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

样例输入

5
1 1
5 1
7 1
3 3
5 5

样例输出

1
2
1
1
0

提示

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

扫描二维码关注公众号,回复: 2721876 查看本文章

解题思路:

和例题1差不多,直接上代码

#include<cstdio>
#include<cstring>
using namespace std;
int x,y,n;
int cnt[32010];
int ans[32010];
int lowbit(int x)
{
	return x&(-x);
}
int sum(int x)
{
	int ans=0;
	while(x>0)
	{
		ans+=cnt[x];
		x-=lowbit(x);
	}
	return ans;
}
void add(int x)
{
	while (x<32010)
	{
		cnt[x]++;
		x+=lowbit(x);
	}
}
int main()
{
	while(scanf("%d",&n)!=EOF && n)
	{
		memset(ans,0,sizeof(ans));
		memset(cnt,0,sizeof(cnt));
		for(int i=0;i<n;i++)
		{
			scanf("%d%d", &x, &y);
			ans[sum(x+1)]++;
			add(x+1);
		}
		for (int i=0;i<n;i++)
			printf("%d\n",ans[i]);
	}
	return 0;
}

猜你喜欢

转载自www.cnblogs.com/Wolfbeyond/p/9463541.html
今日推荐