XYNUOJ暑期集训第二次测试 G - 聪明的木匠

G - 聪明的木匠

一位老木匠需要将一根长的木棒切成N段。每段的长度分别为L1,L2,......,LN(1 <= L1,L2,…,LN <= 1000,且均为整数)个长度单位。我们认为切割时仅在整数点处切且没有木材损失。

木匠发现,每一次切割花费的体力与该木棒的长度成正比,不妨设切割长度为1的木棒花费1单位体力。例如:若N=3,L1 = 3,L2 = 4,L3 = 5,则木棒原长为12,木匠可以有多种切法,如:先将12切成3+9.,花费12体力,再将9切成4+5,花费9体力,一共花费21体力;还可以先将12切成4+8,花费12体力,再将8切成3+5,花费8体力,一共花费20体力。显然,后者比前者更省体力。

那么,木匠至少要花费多少体力才能完成切割任务呢?

Input

第1行:1个整数N(2 <= N <= 50000) 
第2 - N + 1行:每行1个整数Li(1 <= Li <= 1000)。

Output

输出最小的体力消耗。

Sample Input

3
3
4
5

Sample Output

19
#include<cstdio>
#include<queue>
#include<vector>
#define M 100000
using namespace std;

int main()
{
	int n;
	int sum=0;
	int a[M];
	scanf("%d",&n);
	priority_queue<int,vector<int>,greater<int> >q;//这道题用优先队列
	for(int i=0; i<n; i++)
	{
		scanf("%d",&a[i]);
		q.push(a[i]);
	}
	while(q.size()!=1 )//当q只剩一个数的时候退出循环
	{
		int x=q.top();
		q.pop() ;
		int y=q.top() ;
		q.pop();
		sum=sum+x+y;
		q.push(x+y);
	}
	printf("%d\n",sum);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/yxy602843889/article/details/81292239