Antenna Placement poj3020(二分图最大匹配/最小路径覆盖)

版权声明:有错误还请斧正,感激不尽。 https://blog.csdn.net/Gentle_Guan/article/details/54933489


Antenna Placement
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9279   Accepted: 4584

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
 
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5



#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;

#define For(i,a,b) for(i=a;i<=b;i++)
#define Out(x) cout<<x<<endl

#define ll long long
const int inf = 2000;

#ifndef SYMBOL
#define SYMBOL value
#endif

#define SYMBOL
#if defined SYMBOL
#endif
///get 到了有利于调试的语句
bool Map[inf][inf];
bool vis[inf];
int match[inf];

int point,n,m;
int disx[] = {0,-1,1, 0,0};
int disy[] = {0, 0,0,-1,1};
char str[inf][inf];
int pointnum[inf][inf];

bool Dfs(int key)
{
    int i;
    For(i,1,point)
    {
        if(Map[key][i] == 1 && vis[i] == 0)
        {
            vis[i] = 1;
            if(match[i] == -1 || Dfs(match[i]))
            {
                match[i] = key;
                return 1;
            }
        }
    }
    return 0;
}

int MaxMatch()  ///最大匹配
{
    int i,ans=0;
    For(i,1,point)
    {
        memset(vis,0,sizeof(vis));
        if(Dfs(i))
        {
            ans++;
        }
    }
    return ans;
}

int main()
{
    int i,j,k,x,y,t;
    cin>>t;
    while (t--)
    {
        memset(Map,0,sizeof(Map));
        memset(match,-1,sizeof(match));

        point = 0;
        cin>>n>>m;
        For(i,1,n)
        {
            For(j,1,m)
            {
                cin>>str[i][j];
                if(str[i][j] == '*')
                {
                    point++;
                    pointnum[i][j] = point;
                }
            }
        }
        int k;
        For(i,1,n)
        {
            For(j,1,m)
            {
                if(str[i][j] == '*')
                {
                    For(k,1,4)
                    {
                        x=i+disx[k];
                        y=j+disy[k];
                        if(str[x][y] == '*')  ///两城市相“邻”
                        {
                            Map[pointnum[i][j]][pointnum[x][y]]=1;
                            ///单向
                            ///以point来建立邻接表
                        }
                    }
                }
            }
        }
        Out(point-MaxMatch()/2);
        ///最小路径覆盖=结点-最大匹配数/2
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/Gentle_Guan/article/details/54933489