迷宫dfs+奇偶剪枝

链接地址1

链接地址2

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 91716    Accepted Submission(s): 24937


 

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

 

4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

Sample Output

 

NO YES

这个题要用深搜计算出到达门口时花费时间的所有情况,看是否有等于给定值的!

但是要是直接深搜是一定会超时的,所以要用到奇偶剪枝,不懂得请点击红色字体!

#include<bits/stdc++.h>
using namespace std;

bool vis[60][60];
char vec[60][60];
int n,m,t;
int bx,by,ex,ey;
int flag=0;
int num=0;
int dir[4][2]={0,1,0,-1,1,0,-1,0 };

bool jud(int x,int y,int ex,int ey,int num){//奇偶减枝; 
	int t=abs(ex-x)+abs(ey-y);
	if(t%2 != num%2)
	return 0;
	else 
	return 1;
}

void dfs(int x, int y, int num){
	
	vis[x][y]=1;
	if(num==t && vec[x][y]=='D' ){
		flag=1;
		return ;
	}
	for(int i=0;i<4;i++){
		int dx=x+dir[i][0];
		int dy=y+dir[i][1];
		if( jud( dx, dy, ex, ey, num)==0 ) continue ;
		if(dx<0 || dx>=n || dy<0 || dy>=m )
		continue;
		if(vec[dx][dy]=='X'||vis[dx][dy]==1)
		continue;
		dfs(dx,dy,num+1);
		if(flag) return ;
		else vis[dx][dy]=0;
		}
	}
int main(){
	while(cin>>n>>m>>t,n||m||t){
		
		memset(vis,0,sizeof(vis));
		memset(vec,0,sizeof(vec));
		flag=0;
		for(int i=0;i<n;i++){
			cin>>vec[i];
		}
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				if(vec[i][j]=='S'){
					bx=i;
					by=j;
				}
				if(vec[i][j]=='D'){
					ex=i;
					ey=j;
				}
			}
		}
	
		dfs(bx,by,0);
		if(flag)
		cout<<"YES"<<endl;
		else
		cout<<"NO"<<endl;
	}
	return 0;
} 


猜你喜欢

转载自blog.csdn.net/guozuofeng/article/details/81335158