hdu1010(DFS+奇偶剪枝)

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 
InputThe input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 
OutputFor each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 
Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
Sample Output
NO
YES

关于奇偶剪枝,

奇偶剪枝:

是数据结构的搜索中,剪枝的一种特殊小技巧。

现假设起点为(sx,sy),终点为(ex,ey),给定t步恰好走到终点,

 

s

 

 

 

 

|

 

 

 

 

|

 

 

 

 

|

 

 

 

 

+

e

 

如图所示(“|”竖走,“—”横走,“+”转弯),易证abs(ex-sx)+abs(ey-sy)为此问题类中任意情况下,起点到终点的最短步数,记做step,此处step1=8;

  

s

 

 

+

 

|

+

 

 

 

|

 

 

 

 

+

e

 

如图,为一般情况下非最短路径的任意走法举例,step2=14;

step2-step1=6,偏移路径为6,偶数(易证);

故,若t-[abs(ex-sx)+abs(ey-sy)]结果为非偶数(奇数),则无法在t步恰好到达;

返回,false;

反之亦反。

所以对于任意一个位置(x,y,t)到终点时间为T-t,最短时间为abs(x-ex)+abs(y-ey)

所以一定有T-t-abs(x-ex)-abs(y-ey)为奇数

// 奇偶剪枝 
#include <iostream>
#include <cstring>
using namespace std;
const int maxn=10;
const int maxT=60;
char map[maxn][maxn];
int sx,sy,ex,ey;
int m,n,T;
int flag;
int dir[][2]={{0,1},{1,0},{-1,0},{0,-1}};
void dfs(int x,int y,int t)
{
	if(flag)return; 
	if(t>T)return ;
	if(x==ex&&y==ey&&t==T){
		flag=1;
		return ;
	} 
	int left_t=abs(x-ex)+abs(y-ey);
	int temp=T-t-left_t;
	if(temp&1)return ;
	for(int i=0;i<4;i++){
		int temp_x=x+dir[i][0];
		int temp_y=y+dir[i][1];
		if(map[temp_x][temp_y]=='X'||x<1||x>n||y<1||y>m)continue;
		map[temp_x][temp_y]='X';
		dfs(temp_x,temp_y,t+1);
		map[temp_x][temp_y]='.';
	}
}
int main()
{
	
	while(cin>>n>>m>>T&&m||n||T){
		int num=0;
		for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++){
			cin>>map[i][j];
			if(map[i][j]=='S'){
				sx=i;
				sy=j;
				map[i][j]='X';
			}
			if(map[i][j]=='D'){
				ex=i;
				ey=j;
			}
			if(map[i][j]=='X'){
				num++;
			}
		}
		flag=0;
		if(n*m-num>=T) 
		dfs(sx,sy,0);
		if(flag)cout<<"YES"<<endl;
		else
		cout<<"NO"<<endl;
	} 
    return 0;
}



猜你喜欢

转载自blog.csdn.net/Jamence/article/details/78739695