欧法 求 逆元

/*
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
Input
数据的第一行是一个T,表示有T组数据。 
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
Output
对应每组数据输出(A/B)%9973。
Sample Input
2
1000 53
87 123456789
Sample Output
7922
6060
*/

/*
根据公式  (a/b)%c = (a*d)%c = ((a%c)*(d%c))%c;
 d 是  b 的逆元;
 
 而  d 可 用  欧法  求得
 
 故 有; 
*/

#include<iostream>
#include<stdio.h>
typedef long long ll; 
ll extend_gcd(ll a,ll b,ll &x,ll &y)
{
    if(b==0)
    {
        x = 1;
        y=0;
        return a;
    }
    else 
    {
        int r=extend_gcd(b,a%b,x,y);
    int t=x;
    x=y;
    y=t-(a/b)*y;
    return r;
    }
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        long long x,y;
        long long a,b;
        long long w = 9973;
        scanf("%lld%lld",&a,&b);
        extend_gcd(b,9973,x,y);
        x = (x+w)%w;
        printf("%lld\n",x);
        printf("%lld\n",(a*x%w)%w);
    }
}

猜你喜欢

转载自blog.csdn.net/lijianzhong1/article/details/81226512