HDU 2602:Bone Collector(dp 背包)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 82378    Accepted Submission(s): 34087


 

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

Sample Input

1 5 10 1 2 3 4 5 5 4 3 2 1

 

Sample Output

14

Author

Teddy

 

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

题解:最经典的背包入门题目,注意不要把value跟volume输反(囧)

状态转移方程:f [ i ] [ v ] = max ( f  [ i - 1 ] [ v ] , f [ i -1 ] [ v - c [ i ] ] + w [ i ] )

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,v;
        cin>>n>>v;
        int volume[1005];
        int value[1005];
        int dp[1005];
        memset(volume,0,sizeof(volume));
        memset(value,0,sizeof(value));
        for(int i=0;i<n;i++)
            cin>>value[i];
        for(int i=0;i<n;i++)
            cin>>volume[i];
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
            for(int j=v;j>=volume[i];j--)
            dp[j]=max(dp[j],dp[j-volume[i]]+value[i]);
        printf("%d\n",dp[v]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42671353/article/details/81357418
今日推荐