SDUT OJ 数据结构实验之排序三:bucket sort

数据结构实验之排序三:bucket sort

Time Limit: 250 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

根据人口普查结果,知道目前淄博市大约500万人口,你的任务是帮助人口普查办公室按年龄递增的顺序输出每个年龄有多少人,其中不满1周岁的按0岁计算,1到2周岁的按1岁计算,依次类推,大于等于100岁的老人全部按100岁计算。

Input

 输入第一行给出一个正整数N(<=5000000),随后连续给出N个整数表示每个人的年龄,数字间以空格分隔。

Output

 按年龄递增的顺序输出每个年龄的人口数,人口数为0的不输出,每个年龄占一行,数字间以一个空格分隔,行末不得有多余空格或空行。

Sample Input

10
16 71 17 16 18 18 19 18 19 20

Sample Output

16 2
17 1
18 3
19 2
20 1
71 1

Hint

Source

xam

#include <bits/stdc++.h>

using namespace std;
int aa[120];
int main()
{
    int n;
    memset(aa,0,sizeof(aa));
    cin>>n;
    for(int i=0; i<n; i++)
    {
        int x;
        scanf("%d",&x);
        if(x>=100)
            x=100;
        aa[x]++;
    }
    for(int i=0; i<=100; i++)
    {
        if(aa[i]!=0)
            printf("%d %d\n",i,aa[i]);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81301332