SDUT oj数据结构实验之栈与队列三:后缀式求值

数据结构实验之栈与队列三:后缀式求值

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

对于一个基于二元运算符的后缀表示式(基本操作数都是一位正整数),求其代表的算术表达式的值。

Input

输入一个算术表达式的后缀式字符串,以‘#’作为结束标志。

Output

求该后缀式所对应的算术表达式的值,并输出之。

Sample Input

59*684/-3*+#

Sample Output

57

Hint

基本操作数都是一位正整数!

Source

#include<stdio.h>
#include<string.h>
int top=0,i,b[1000];
int main()
{
    char s;
    while(scanf("%c",&s),s!='#')
    {
        if(s>='0'&&s<='9')
        {
            b[++top]=s-'0';
        }
        else if(s=='+'||s=='-'||s=='*'||s=='/')
        {
            if(s=='+')
            {
                b[top-1]=b[top-1]+b[top];
                top--;
            }
            if(s=='-')
            {
               b[top-1]=b[top-1]-b[top];
                top--;
            }
            if(s=='*')
            {
                b[top-1]=b[top-1]*b[top];
                top--;
            }
            if(s=='/')
            {
                b[top-1]=b[top-1]/b[top];
                top--;
            }
        }
    }
    printf("%d\n",b[top]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81107969