SDUT 3373 数据结构实验之查找一:二叉排序树

数据结构实验之查找一:二叉排序树

Time Limit: 400MS Memory Limit: 65536KB

Submit Statistic

Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出”Yes”,否则输出”No”。

Example Input

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

Example Output

Yes
No
No

///递归思想
# include <bits/stdc++.h>
using namespace std;
struct node
{
    int data;
    struct node *r, *l;
};
bool flag;
void creat(struct node *&head, int n)
{
    if(!head)
    {
        head=new struct node;
        head->data=n;
        head->l=head->r=NULL;
    }
    else
    {
        if(head->data>n)
            creat(head->l,n);
        else
            creat(head->r,n);
    }
}
void judge(struct node *head1, struct node *head2)
{
    if(head1&&head2)
    {
        if(head1->data!=head2->data)
        {
            flag=false;
            return;
        }
        judge(head1->l,head2->l);
        judge(head1->r,head2->r);
    }
}
int main()
{
    int N, L;
    while(cin>>N>>L)
    {
        struct node *head=NULL;
        int n;
        for(int i=0;i<N;i++)
        {
            cin>>n;
            creat(head,n);
        }
        while(L--)
        {
            flag=true;
            struct node *head1=NULL;
            for(int i=0;i<N;i++)
            {
                cin>>n;
                creat(head1,n);
            }
            judge(head,head1);
            if(flag)
                cout<<"Yes"<<endl;
            else
                cout<<"No"<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37495823/article/details/78874023