【2016 CCPC 网络赛 】A A water problem

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4839    Accepted Submission(s): 1594


 

Problem Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year. 

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input

There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

 

Output

For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

 

Sample Input

10001
0
333

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO

Author

UESTC

Source

2016中国大学生程序设计竞赛 - 网络选拔赛

问题链接:HDU5832 A water problem

问题描述:给出一个数N(位数不超过10000000),如果N是73和173的倍数的话输出YES,否则输出NO

题解:由于位数太多,使用Java的大数类会超内存,此题没有必要使用高精度,由于73和137的最小公倍数是10001,因此按位边乘边取模就行。

AC的C++程序:

#include<iostream>
#include<string>

using namespace std;

int main()
{
	string s;
	int cnt=1;
	while(cin>>s)
	{
		int sum=0;
		for(int i=0;i<s.length();i++)
		  sum=(sum*10+s[i]-'0')%10001;//10001是73和137的最小公倍数 
		cout<<"Case #"<<cnt++<<": "; 
		if(sum==0)
		  cout<<"YES"<<endl;
		else
		  cout<<"NO"<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/81675416
今日推荐