(快速幂+素数判断)poj3641 Pseudoprime numbers

传送门:poj3641 Pseudoprime numbers

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

吐舌头题意对于非素数p,如果存在a的p次幂对p取模等于a,那么这个数就是伪素数。

判断伪素数的步骤:1.判断p是否是素数?

                               2.判断a的p次幂对p取模是否等于a?由于这里p非常大,所以需要用到快速幂。

#include<iostream>
#include<cmath>
using namespace std;

bool isPrime(int x){
	if(x==2) return true;
	for(int i=2;i<=sqrt(x);i++){
		if(x%i==0) return false;
	}
	return true;
}

long long PowerMod(long long a,long long b,long long c){
	long long ans=1;
	a=a%c;
	while(b>0){
		if(b&1) ans=(ans*a)%c;
		b>>=1;
		a=(a*a)%c;
	}
	return ans;
}

int main(){
	int p,a;
	while(cin>>p>>a){
		if(p==0&&a==0) break;
		if(isPrime(p)) cout<<"no"<<endl;
		else if(PowerMod(a,p,p)==a) cout<<"yes"<<endl;
		else cout<<"no"<<endl;
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_37275680/article/details/80960705