H - Pseudoprime numbers

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

ac代码:

#include<stdio.h>

typedef long long ll;

int isprem(long long p)

{

for(int i=2;i*i<=p;i++) if(p%i==0) return 0; return 1;

}

int main()

{

ll a,p; while(scanf("%lld %lld",&p,&a)!=EOF && (a||p))

{

ll t,m; t=p; m=a;

if(isprem(p)) printf("no\n");

else

{

ll ans=1; while(p)

{

if(p&1) ans=ans*a%t;

a=a*a%t;

p>>=1;

}

if(ans==m) printf("yes\n");

else printf("no\n");

}

}

return 0;

}

猜你喜欢

转载自blog.csdn.net/laisuwen_123/article/details/81162706