Pseudoprime numbers

Fermat’s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input
Input contains several test cases followed by a line containing “0 0”. Each test case consists of a line containing p and a.

Output
For each test case, output “yes” if p is a base-a pseudoprime; otherwise output “no”.

Sample Input
3 2
10 3
341 2
341 3
1105 2
1105 3
0 0
Sample Output
no
no
yes
no
yes
yes

#include <stdio.h>
#include<math.h>

typedef long long ll;
ll pow_mod(ll a, ll n, ll MOD) {
    ll res = 1;
    while (n) {
        if(n&1) res = res * a % MOD;
        a = a * a % MOD;
        n >>= 1;
    }
    return res ;
}

int is_prime (int p)
{
    int j, k = 0;
    for (j = 2; j <= sqrt(p); j++)
    {
        if(p % j == 0)
        {
            k ++; break;
        }
    }
    if ( k > 0) return 0;
    else return 1;
}

int main()
{
    int p, a;
    while (~scanf("%d%d", &p, &a) && p+a)
    {
        if (is_prime(p)) printf("no\n");
        else
        {
            printf("%s\n", a == pow_mod(a, p, p) ? "yes" : "no");
        }
    }
    return 0;
}

用到了一个快速幂和素数判定的知识。

猜你喜欢

转载自blog.csdn.net/hqzzbh/article/details/81118080