POJ 3641 Pseudoprime numbers

Fermat’s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing “0 0”. Each test case consists of a line containing p and a.

Output

For each test case, output “yes” if p is a base-a pseudoprime; otherwise output “no”.

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

题意描述:给出两个longlong范围的数p和a,如果a的p次幂对p取余且余数为a,则p的某些(但不是很多)非素数值,称为base-a伪素数。

解题思路:首先判断p是否为素数,如果p为素数输出no,否则继续判断a的p次幂,用快速幂的方法去求出a的p次幂对p取余的余数。

AC代码

#include<stdio.h>

bool prime(long long p)
{
	for(int i=2;i*i<p;i++)
		if(p%i==0)
			return 0;
	return 1;
}

long long cm(long long a,long long p)
{
	long long ans=1,res=a,mod=p;
	while(p!=0){
		if(p&1)
			ans=ans*res%mod;
		res=res*res%mod;
		p>>=1;
	}
	return ans%mod;
}

int main(void)
{
	long long a,p;
	while(~scanf("%lld%lld",&p,&a)){
		if(a==0&&p==0)
			break;
		if(prime(p)==1)
			printf("no\n");
		else if(cm(a,p)==a)
			printf("yes\n");	
		else
			printf("no\n"); 
	}
	return 0;
}
发布了53 篇原创文章 · 获赞 1 · 访问量 1334

猜你喜欢

转载自blog.csdn.net/fgets__/article/details/104188563