【POJ 1995】Raising Modulo Numbers(快速幂)

Raising Modulo Numbers


Description

People are different. Some secretly read magazines full of interesting girls’ pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players’ experience it is possible to increase the difficulty by choosing higher numbers.

You should write a program that calculates the result and is able to find out who won the game.


Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.
Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression
(A1B1+A2B2+ … +AHBH)mod M.


Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132
Sample Output

2
13195
13


题意:

求ai的bi次幂的和再取模M。

快速幂:

顾名思义,快速幂就是快速算底数的n次幂。其时间复杂度为 O(log₂N), 与朴素的O(N)相比效率有了极大的提高。
关键在于位运算(&和<<)的运用。

模板:

int pow4(int a,int b){
  int r=1,base=a;
  while(b){
    if(b&1) r*=base;
    base*=base;
    b>>=1;
  }
  return r;
}

这一篇文章举了例子,可以一看->传送门

思路:

这道题就是用快速幂的裸题,权当快速幂入门了吧。

代码:

#include<iostream>
using namespace std;

long long q_pow(int a,int b,int mod)
{
    long long r=1,base=a;
    while(b)
    {
        if(b&1)
            r=r*base%mod;
        base=((base%mod)*(base%mod))%mod;
        b>>=1;
    }
    return r;
}

int main()
{
    long long ans,T,n,mod,a,b;
    cin>>T;
    while(T--)
    {
        ans=0;
        cin>>mod>>n;
        while(n--)
        {
            cin>>a>>b;
            ans+=q_pow(a,b,mod);
            ans%=mod;
        }
        cout<<ans<<endl;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/chen_yuazzy/article/details/77619662