POJ 1486 Sorting Slides(二分图匹配)

                                                                                        Sorting Slides

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5048   Accepted: 1976

Description

Professor Clumsey is going to give an important talk this afternoon. Unfortunately, he is not a very tidy person and has put all his transparencies on one big heap. Before giving the talk, he has to sort the slides. Being a kind of minimalist, he wants to do this with the minimum amount of work possible. 

The situation is like this. The slides all have numbers written on them according to their order in the talk. Since the slides lie on each other and are transparent, one cannot see on which slide each number is written. 


Well, one cannot see on which slide a number is written, but one may deduce which numbers are written on which slides. If we label the slides which characters A, B, C, ... as in the figure above, it is obvious that D has number 3, B has number 1, C number 2 and A number 4. 

Your task, should you choose to accept it, is to write a program that automates this process.

Input

The input consists of several heap descriptions. Each heap descriptions starts with a line containing a single integer n, the number of slides in the heap. The following n lines contain four integers xmin, xmax, ymin and ymax, each, the bounding coordinates of the slides. The slides will be labeled as A, B, C, ... in the order of the input. 

This is followed by n lines containing two integers each, the x- and y-coordinates of the n numbers printed on the slides. The first coordinate pair will be for number 1, the next pair for 2, etc. No number will lie on a slide boundary. 

The input is terminated by a heap description starting with n = 0, which should not be processed. 

Output

For each heap description in the input first output its number. Then print a series of all the slides whose numbers can be uniquely determined from the input. Order the pairs by their letter identifier. 

If no matchings can be determined from the input, just print the word none on a line by itself. 

Output a blank line after each test case. 

Sample Input

4
6 22 10 20
4 18 6 16
8 20 2 18
10 24 4 8
9 15
19 17
11 7
21 11
2
0 2 0 2
0 2 0 2
1 1
1 1
0

Sample Output

Heap 1
(A,4) (B,1) (C,2) (D,3)

Heap 2
none 

题目大意:有几张幻灯片,每个幻灯片有一个数字,幻灯片是透明的,让你输出确定的幻灯片

先把图建起来,然后跑匈牙利,先得到一个最大匹配,然后我们将最大匹配的边依次删去,将剩下的边再跑最大匹配,如果两次的最大匹配数相同,则说明删去的这条边是不必要的(因为要不要这条边都能跑出个数目一样的最大匹配),如果不同,则说明这个是必要的边,可以输出

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1010;
int n;
int map[maxn][maxn];
int match[maxn];
int tmp_match[maxn];
bool vis[maxn];
struct Node
{
	int xmin;
	int xmax;
	int ymin;
	int ymax;
}node[maxn];
bool dfs(int node)
{
	for(int i=0;i<n;i++)
	{
		if(!vis[i]&&map[node][i])
		{
			vis[i]=true;
			if(match[i]==-1||dfs(match[i]))
			{
				match[i]=node;
				return true;
			}
		}
	}
	return false;
}
int hungry()
{
	int ans=0;
	memset(match,-1,sizeof(match));
	for(int i=0;i<n;i++)
	{
		memset(vis,false,sizeof(vis));
		if(dfs(i))
		{
			ans++;
		}
	}
	return ans;
}
int main()
{
	int cas=1;
	while(~scanf("%d",&n))
	{
		if(!n) break;
		memset(map,0,sizeof(map));
		memset(tmp_match,-1,sizeof(tmp_match));
		for(int i=0;i<n;i++)
		{
			scanf("%d%d%d%d",&node[i].xmin,&node[i].xmax,&node[i].ymin,&node[i].ymax);
		}
		for(int i=0;i<n;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			for(int j=0;j<n;j++)
			{
				if(node[j].xmin<=x&&x<=node[j].xmax&&node[j].ymin<=y&&y<=node[j].ymax)
				{
					map[i][j]=1;
				}
			}
		}
		int res=hungry();
		int flag=0;
		printf("Heap %d\n",cas++);
		for(int i=0;i<n;i++)
		{
			tmp_match[i]=match[i];
		}
		for(int i=0;i<n;i++)
		{
			map[tmp_match[i]][i]=0;
			if(hungry()==res)
			{
				continue;
			}
			else
			{
				if(flag) putchar(' ');
				printf("(%c,%d)",'A'+i,tmp_match[i]+1);
				flag++;
			}
			map[tmp_match[i]][i]=1;
		}
		if(!flag) printf("none");
		printf("\n\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37943488/article/details/81093173