POJ 1469 COURSES 二分图最大匹配

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student 1 1 Student 1 2 ... Student 1 Count1 
Count2 Student 2 1 Student 2 2 ... Student 2 Count2 
... 
CountP Student P 1 Student P 2 ... Student P CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

题意:2组数据,有3门课,3个学生,给出第i门课有j个人选择,分别是A0,A1,A2。。。求是否可以1每个学生选择一个不同的课程 2每个课程都有不同的代表 ,则把学生和课程作为二分图的两个集合,然后最大匹配==课程数的话就YES。

#include<stdio.h>
#include<string.h>
#include<string>
#include<math.h>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m,ma[505][505],vis[505],dx[505];
int find(int i)
{
	for(int j=1;j<=m;j++)
	{
		if(ma[i][j]&&vis[j]==0)
		{
			vis[j]=1;
			if(dx[j]==-1||find(dx[j]))
			{
				dx[j]=i;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int t,i,j,tt,sum,x; 
	scanf("%d",&t);
	while(t--)
	{
		memset(ma,0,sizeof ma);
		memset(vis,0,sizeof vis);
		memset(dx,-1,sizeof dx);
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
		{
			scanf("%d",&tt);
			for(j=1;j<=tt;j++)
			{
				scanf("%d",&x);
				ma[i][x]=1;
			}
		}
		sum=0;
		for(i=1;i<=n;i++)
		{
			memset(vis,0,sizeof vis);
			sum+=find(i);
		}
		//printf("%d\n",sum);
		if(sum==n)
		printf("YES\n");
		else
		printf("NO\n");
	}
} 

猜你喜欢

转载自blog.csdn.net/thewise_lzy/article/details/79864752