POJ1007-DNA Sorting

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA


#include<iostream>

#include<algorithm>
#include<string>//不加的话会complication error,但是在codeblock不会有问题
using namespace std;
struct node{
string s;
int c;
}dna[100];
bool cmp(node x,node y){
   return x.c<y.c;
}


int main()
{
   int n,m;
   cin>>n>>m;//m是dna的个数,n是dna的长度
   for(int i=0;i<m;i++){
            cin>>dna[i].s;
            int c=0;
        for(int j=0;j<n;j++){
            for(int k=j+1;k<n;k++){
                if(dna[i].s[j] > dna[i].s[k])//两个字符可以直接比较大小
                    c++;
            }
         dna[i].c=c;
        }
    }
    sort(dna,dna+m,cmp);//一开始这里写成了n,头疼
    for(int i=0;i<m;i++)
//一开始写的cmp从大到小排序,这里从i=n-1,开始,错误的根本原因,当两个串大小相等时,排在前面的应该先写
        cout<<dna[i].s<<endl;
     return 0;

}




#include <iostream>
using namespace std;
struct node{
char a[50];
}b[100];
int main()
{
    for(int i=0;i<3;i++)
        cin>>b[i].a;
    for(int i=0;i<3;i++)
        cout<<b[i].a<<endl;

}看别的答案时发现,char类型不按enter可以连着输

猜你喜欢

转载自blog.csdn.net/redredblue/article/details/80445067