POJ 1007 DNA Sorting

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 108156   Accepted: 43326

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m;
struct nond{
    char s[1000];
    int wwf;
}v[1000];
int cmp(nond a,nond b){
    return a.wwf<b.wwf;
}
void work(int pos){
    for(int i=0;i<n;i++)
        for(int j=i+1;j<n;j++)
            if(v[pos].s[i]>v[pos].s[j])
                v[pos].wwf++;
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++){
        for(int j=0;j<n;j++)
            cin>>v[i].s[j];
        work(i);
    }
    //cout<<endl; 
    sort(v+1,v+1+m,cmp);
    for(int i=1;i<=m;i++){
        for(int j=0;j<n;j++)
            cout<<v[i].s[j];
        cout<<endl;
    }
}
/*
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
*/

猜你喜欢

转载自www.cnblogs.com/cangT-Tlan/p/9246395.html