【POJ 2505】A multiplication game(博弈)

题意描述:Stan和Ollie玩游戏,两人轮流,首先Stan开始把1乘以一个2到9之间的整数,接着Ollie再将前一个数乘以一个2到9之间的整数。最先使这个数不小于n的人获胜。

解题思路:与其说是博弈,不如说是找到了规律,S胜:2-9(0+2)——9;O胜:10-18 (9+1)——9*2;S胜:19-162 (2*9+1)——9*2*9;O胜:163-324 (9*2*9+1)——9*2*9*2;S胜:324-2916 (9*2*9*2+1)——9*2*9*2*9。

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either
Stan wins.
or
Ollie wins.
assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

AC代码 

#include<stdio.h>
#include<string.h>
int main()
{
	int a[25],n,i;
	while(~scanf("%d",&n))
	{
		int ans=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			ans=ans^a[i];
		}
		if(ans==0)
			printf("No\n");
		else
			printf("Yes\n");
	}
	return 0;
}

努力努力再努力

猜你喜欢

转载自blog.csdn.net/zz_xun/article/details/120225162