Milking Time C++

题目:

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43

题意:

有一个勤劳的奶牛,她在每个时间段产z的奶,让我们求她在n时间段内最多产奶量,并且每一段时间不能重叠。

思路:

先用一个结构体输入,并且把每个结束时间加上休息时间。然后按开始时间从小到大排序。从最初开始遍历,记录每一段时间的加上它之前能包含时间的最大产奶量。

代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
struct st
{
    long long int x,y,z;
}a[1001];
bool cmp(st A,st B)
{
    return A.x<B.x;
}
int main()
{
    long long int n,m,r,i;
    while(cin>>n>>m>>r)
    {
        for(i=0;i<m;i++)
        {
            cin>>a[i].x>>a[i].y>>a[i].z;
            a[i].y=a[i].y+r;
        }
        sort(a,a+m,cmp);
        long long int dp[1001];
        memset(dp,0,sizeof(dp));
        long long int MAX=0;
        for(i=0;i<m;i++)
        {
            dp[i]=a[i].z;
            for(int j=0;j<i;j++)
            {
                if(a[j].x<a[i].x&&a[j].y<=a[i].x)
                {
                    dp[i]=max(dp[i],dp[j]+a[i].z);
                }
            }
            if(MAX<dp[i])MAX=dp[i];
        }
        cout<<MAX<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zero_979/article/details/80613431
今日推荐