poj1328贪心

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1
我是记录观察到每一个岛屿的最右边的雷达的位置,进行排序,在使用贪心的思想去递推

#include<iostream>
#include <cmath>
#include <set>
#include <algorithm>
using namespace std;
const double eps=1e-9;
int n,d;
const int maxn=1000+10;
struct node{
    double x,y,t;
    friend bool operator <(node a,node b){
        return a.t<b.t;
    }
}p[maxn];
bool is_ok(node a,double x,double y){
    return (x-a.x)*(x-a.x)+(y-a.y)*(y-a.y)-d*d<=eps;
}
int main()
{

    int ncase=1;
    while(cin>>n>>d){
        if(n==0&&d==0)break;
        int no=0;
        for(int i=0;i<n;i++){
            cin>>p[i].x>>p[i].y;
            if(p[i].y>d)no=1;
            p[i].t=p[i].x+pow(d*d-(p[i].y)*(p[i].y),0.5);
        }
  //      cout<<endl;
        if(no)cout<<"Case "<<ncase++<<": "<<-1<<endl;
        else{
            sort(p,p+n);
 //           for(int i=0;i<n;i++)cout<<p[i].x<<" "<<p[i].y<<endl;

            node cur;
            bool flag=false;
            int num=0;
            for(int i=0;i<n;){
                while(is_ok(cur,p[i].x,p[i].y)&&i<n&&flag){
                    i++;
                }
                if(i>=n)break;
                cur.x=p[i].x+pow(d*d-(p[i].y)*(p[i].y),0.5);
                cur.y=0;
                flag=true;
 //               cout<<"radar: "<<cur.x<<" "<<cur.y<<endl;
                num++;
                i++;
            }
            cout<<"Case "<<ncase++<<": "<<num<<endl;
        }

    }
}




猜你喜欢

转载自blog.csdn.net/Jamence/article/details/79237423