POJ 1328 Radar Installation(贪心算法)

 Radar Installation

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Input

The input consists of several test cases. The first line of each case contains two integers n (1 n 1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros.


Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.


Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0


Sample Output

Case 1: 2
Case 2: 1

题目大意:x轴上面有N个P点,给你一个d表示半径,问在x轴上需要几个半径为d的点才能将所有P点覆盖。

题解:贪心算法。算出p点到x轴上距离为d的区间【x1,x2】然后按照x2排序,查区间重叠的部分。

具体代码如下:

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
typedef struct{
	int X,Y;
	double x1,x2;
}point;
bool cmp(point a,point b)
{
	return a.x2<b.x2;
}
int main()
{
	int n,num=0;
	double d;
	while(cin>>n,cin>>d,n&&d)
	{
		num++;
		int i;
		point *a;
		a=new point[n+1];
		int flag=0;
		for(i=0;i<n;i++)
		{	
			cin>>a[i].X>>a[i].Y;
			if(d*d-a[i].Y*a[i].Y*1.0>=0.0)
			{
				a[i].x1=a[i].X*1.0-sqrt(d*d-a[i].Y*a[i].Y*1.0);
				a[i].x2=a[i].X*1.0+sqrt(d*d-a[i].Y*a[i].Y*1.0);
			}else{
				flag=1;
				break;
			}				
		}	
		if(flag==1)
			cout<<"Case "<<num<<": -1"<<endl;
		else
		{	
			sort(a,a+n,cmp);				
			double p=a[0].x2;
			int final=1;
			for(i=0;i<n;i++)
			{
				if(a[i].x1<=p)
				{
					continue;
				}else{
					final++;
					p=a[i].x2;
				}
			}
			cout<<"Case "<<num<<": "<<final<<endl;
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42391248/article/details/81148443