POJ1328 Radar Installation #区间贪心#

Radar Installation

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 135401   Accepted: 29732

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.


Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

Beijing 2002

Solution

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
    typedef pair<double, double> p;
    int n, d, k = 0;
    while (scanf("%d%d", &n, &d) == 2 && (n || d))
    {
        vector<p> intv;
        bool flag = false;
        for (int i = 0; i < n; i++)
        {
            int x, y;
            scanf("%d%d", &x, &y);
            if (d < y) flag = true;
            double x1 = x - sqrt(d * d - y * y);
            double x2 = x + sqrt(d * d - y * y);
            intv.push_back(p(x1, x2));
        }
        if (flag) printf("Case %d: %d\n", ++k, -1);
        else
        {
            sort(intv.begin(), intv.end());
            int cnt = 1;
            double r_last = intv[0].second;
            for (int i = 1; i < n; i++)
            {
                double l_now = intv[i].first;
                double r_now = intv[i].second;
                if (r_last >= l_now) r_last = min(r_last, r_now);
                else
                {
                    cnt++;
                    r_last = r_now;
                }
            }
            printf("Case %d: %d\n", ++k, cnt);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35850147/article/details/106167080