Radar Installation - poj1328 - 贪心(区间)、几何

Radar Installation

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 106225   Accepted: 23577

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 

 
Figure A Sample Input of Radar Installations


 

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

Beijing 2002

思路:

刚开始这样想(错的):按点的横坐标递增排序后,画第一个圆,让第一个点的正好在圆的边界,然后往后找到第一个不在圆内的点重复画圆的操作,这样是错误的原因如图:

这样可能导致第二个点不在范围内,ans又要多加1

正确做法:

以每个点为圆心画圆,存的是圆与x,y轴的左右交点横坐标,然后转换成区间问题

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
 
using namespace std;

struct A{
	double l,r;
}qujian[1005];
double d;

bool cmp(A a,A b){
	return a.r<b.r;
}

int main(){
	int n,t=0;
	double x,y;
	while(scanf("%d%lf",&n,&d)){
		t++;
		if(n==0&&d==0)break;
		int flag=0;
		for(int i=0;i<n;i++){
			scanf("%lf%lf",&x,&y);
			double tmp=sqrt(d*d-y*y);
			qujian[i].l=x-tmp;
			qujian[i].r=x+tmp;
			if(y>d)flag=1;
		}
		if(flag){printf("Case %d: -1\n",t);continue;}
		int ans=1;
		sort(qujian,qujian+n,cmp);
		double k=qujian[0].r;
		for(int i=1;i<n;i++){
			if(qujian[i].l>k){
				ans++;
				k=qujian[i].r;
			}
		}
		printf("Case %d: %d\n",t,ans);
	}
}

猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/81274056