Radar Installation POJ - 1328(贪心)

Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 107553   Accepted: 23886

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1


题意:x轴上方有岛屿,放雷达(半径为r),最少数量覆盖
题解:雷达画圈找区间即可
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<map>
#include<set>
using namespace std;
#define INF 0x3f3f3f3f
const int maxn=1005;

int ca=0,n,d;
struct
{
    double x;
    double y;
}isl[maxn];

struct r
{
    double st;
    double en;
}data[maxn];

bool cmp(r a,r b)
{
    
    if(a.en < b.en)
        return true;
    else
        return false;
}

int main()
{
    int i,j,ans;
   while(scanf("%d %d",&n,&d) && (n||d))
   {
       int vis[maxn]={0};
       ans=0;
     ca++;
       int maxy=0;
       for( i=0;i<n;i++)
       {
           cin>>isl[i].x>>isl[i].y;
            if(isl[i].y>maxy)
                maxy=isl[i].y;
       }
       getchar();
       getchar();
           
        printf("Case %d: ",ca);
       if(maxy>d || d<0)
       {
           cout<<-1<<endl;
           continue;
       }
       for( i=0;i<n;i++)
       {
           data[i].st=isl[i].x-sqrt(d*d-isl[i].y*isl[i].y);
           data[i].en=isl[i].x+sqrt(d*d-isl[i].y*isl[i].y);
       }
       sort(data,data+n,cmp);
       for(i = 0; i < n; i ++)
       {                                     //  类似的活动选择。
           if(!vis[i])
           {
               vis[i] = true;
               for(j = 0; j < n; j ++)
                   if(!vis[j] && data[j].st <= data[i].en)
                       vis[j] = true;
               ans ++;
           }
       }
       cout << ans << endl;
       
   }
}

猜你喜欢

转载自www.cnblogs.com/smallhester/p/9499852.html