PAT甲级 1009 Product of Polynomials

1009 Product of Polynomials (25)(25 分)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

方法一:

通过两个输入数组和一个结果数组进行。

代码如下:

#include <iostream>
#include <stdio.h>
using namespace std;

int main(){
   float f_1[1001] = {0.0};//都是浮点数直接用浮点数组,下标要是1001 
   
   int k,a;
   float b;
   cin>>k;
   for(int i=0;i<k;i++){
		cin>>a;
		cin>>b;
		f_1[a] += b;
   }
   
   float f_2[1001] = {0.0};
   cin>>k;
   for(int i=0;i<k;i++){
		cin>>a;
		cin>>b;
		f_2[a] += b;
   }
   
   float res[2001] = {0.0};
   for(int i=0;i<1001;i++){//需要注意下标是1001 
		for(int j=0;j<1001;j++){
			if(f_1[i] != 0.0)
			{
				if(f_2[j] != 0.0)//当两个系数都不为0时才计算 
				{
					res[i+j] += (f_1[i] * f_2[j]);
				}
			}		
		}
   }
   
    int cnt = 0;
	for(int i = 0;i<2001;i++)
		if(res[i] != 0.0)
				cnt++;
		
	cout<<cnt;
	for(int i = 2000;i>=0;i--)
		if(res[i] != 0.0)
				printf(" %d %.1f",i,res[i]);

   return 0;
}

方法二:

通过一个输入数组,在输入第二个数组的数时直接将结果存入一个结果数组。

代码如下:

#include <iostream>
#include <stdio.h>
using namespace std;

int main(){
   float f_1[1001] = {0.0};//都是浮点数直接用浮点数组,下标要是1001 
   
   int k,a;
   float b;
   cin>>k;
   for(int i=0;i<k;i++){
		cin>>a;
		cin>>b;
		f_1[a] += b;
   }
   
   float f_2[1001] = {0.0};
   cin>>k;
   for(int i=0;i<k;i++){
		cin>>a;
		cin>>b;
		f_2[a] += b;
   }
   
   float res[2001] = {0.0};
   for(int i=0;i<1001;i++){//需要注意下标是1001 
		for(int j=0;j<1001;j++){
			if(f_1[i] != 0.0)
			{
				if(f_2[j] != 0.0)//当两个系数都不为0时才计算 
				{
					res[i+j] += (f_1[i] * f_2[j]);
				}
			}		
		}
   }
   
    int cnt = 0;
	for(int i = 0;i<2001;i++)
		if(res[i] != 0.0)
				cnt++;
		
	cout<<cnt;
	for(int i = 2000;i>=0;i--)
		if(res[i] != 0.0)
				printf(" %d %.1f",i,res[i]);

   return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/80968212