PAT 1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NOextra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

我的代码: 

#include<stdio.h>

int main()
{
	int a,b,x,j,i; 
	double m,n[1005]={},w[1005]={},neww[2006]={};
	scanf("%d",&a);
	for(i=0;i<a;i++)
	{
		scanf("%d%lf",&x,&m);
		n[x] += m;
	}
	scanf("%d",&b);
	for(i=0;i<b;i++)
	{
		scanf("%d%lf",&x,&m);
		w[x] += m;
	}
	int sum = 0;
	for(i=1000;i>=0;i--)
	{
		for(j=1000;j>=0;j--)
		{
			if(n[i]&&w[j]) 
				neww[i+j] += n[i]*w[j]; //项数相加系数相乘 
		}
	}
	//项数的范围由于i+j变成了2000+,第一遍我写的i=1000,出现了部分的段错误 
	for(i=2005;i>=0;i--)
		if(neww[i]) sum++;
	printf("%d",sum);
	//i要比数组[]内的数字小1,每次都忘了= =  
	for(i=2005;i>=0;i--)
		if(neww[i]) printf(" %d %.1f",i,neww[i]);
} 

猜你喜欢

转载自blog.csdn.net/Time504/article/details/86591492