PAT1009. Product of Polynomials (25)

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

没考虑输入系数为0的情况,测试点一卡了半天

#include <iostream>
#include <algorithm>
#include <string>
#include <iomanip>
using namespace std;

struct number
{
    int exponents;
    double coefficients;
};

///1009. Product of Polynomials (25)

bool cmp(number a, number b)
{
    return a.exponents > b.exponents;
}

int main()
{
    ios::sync_with_stdio(false);
    int n, m;
    while(cin>>n)
    {
        number nb1[11], nb2[11];
        for(int i=0;i<n;++i)
            cin>>nb1[i].exponents>>nb1[i].coefficients;
        cin>>m;
        for(int i=0;i<m;++i)
            cin>>nb2[i].exponents>>nb2[i].coefficients;
        number nb[105];
        int top = 0;
        bool flag;
        for(int i=0;i<n;++i)
        {
            for(int j=0;j<m;++j)
            {
                double tc = nb1[i].coefficients*nb2[j].coefficients;
                int te = nb1[i].exponents + nb2[j].exponents;
                //cout<<tc<<" "<<te<<endl;
                flag = false;
                for(int k=0;k<top;++k)
                {
                    if(nb[k].exponents == te)
                    {
                        nb[k].coefficients += tc;
                        flag = true;
                        break;
                    }
                }
                if(!flag)
                {
                    nb[top].exponents = te;
                    nb[top++].coefficients = tc;
                }
            }
        }
        sort(nb, nb+top, cmp);
        int maxn = top;
        for(int i=0;i<top;++i)
            if(nb[i].coefficients == 0)
                maxn--;
        cout<<maxn<<" ";
        for(int i=0;i<top;++i)
            if(nb[i].coefficients != 0)
                i==top-1?cout<<nb[i].exponents<<" "<<fixed<<setprecision(1)<<nb[i].coefficients<<endl:cout<<nb[i].exponents<<" "<<fixed<<setprecision(1)<<nb[i].coefficients<<" ";

    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/acsuccess/article/details/78693699